MLAG

Multi-chassis Link Aggregation or vPC (Virtual Port Channel) what Cisco calls it is a type of LAG where a chassis is physically connected to two different chassis for redundancy. MC-LAG adds node-level redundancy to the normal link-level redundancy that a LAG provides.

Arista switches support Multi-Chassis Link Aggregation (MLAG) to logically aggregate ports across two switches.

Arista%20MLAG.png

The following steps are involved in setting up MLAG on Arista EOS.

Step1: Configure a VLAN and under the vlan configuration define it to be used for MLAG.

configure t
vlan 4090
   name mlag-peer
   trunk group mlag-peer

Step 2: Then configure the physical interfaces which will become a peer link.
The two links between the two Arista Leaf switches are Ethernet 11 and Ethernet 12. I will configure them to join channel-group 999.

interface Ethernet11
   description MLAG Peer Link
   channel-group 999 mode active
!
interface Ethernet12
   description MLAG Peer Link
   channel-group 999 mode active
!
!-- then we configure port-channel 999.

interface Port-Channel999
   description MLAG Peer
   switchport mode trunk
   switchport trunk group mlag-peer
   spanning-tree link-type point-to-point

!-- Then we configure mlag and add vlan4090 we configured in the first step and configure a peer address. 
Also we add the port-channel999 that we configured in the previous step to this mlag configuration. 

Leaf-1
mlag configuration
   domain-id leafs
   local-interface Vlan4090
   peer-address 10.0.199.255
   peer-link Port-Channel999

Leaf-2
mlag configuration
   domain-id leafs
   local-interface Vlan4090
   peer-address 10.0.199.254
   peer-link Port-Channel999

Step 3: Now that we have the peer-link setup. We will configure the interfaces connecting to Host-1.

On Leaf-1 the interface is Ethernet 9
On Leaf-2 the interface is Ethernet 10.

!--Leaf-1

interface Ethernet9
   description to Host-1 Eth9 MLAG 121
   channel-group 121 mode active

!-- Leaf-2

interface Ethernet10
   description to Host-1 Eth10 MLAG 121
   channel-group 121 mode active

Step 4: We now configure the port-channel 121 and add mlag 121.

!-- Leaf-1
interface Port-Channel121
   description MLAG for Host-1
   switchport trunk allowed vlan 40
   switchport mode trunk
   mlag 121

!-- Leaf-2
interface Port-Channel121
   description MLAG for Host-1
   switchport trunk allowed vlan 40
   switchport mode trunk
   mlag 121

I have configured port-channel121 and configured the trunk to carry vlan 40 which is the vlan I will use between the host and the leafs.

Step 5: In the last step we will configure the Host interfaces to join the channel-group. From a host point of view the channel-group configuration is exactly the same as you would do for a regular channel-group.

Host-1
interface Ethernet9
   description to Leaf-1 Eth9
   channel-group 121 mode active
!
interface Ethernet10
   description to Leaf-2 Eth10
   channel-group 121 mode active
!
interface Port-Channel121
   switchport trunk allowed vlan 40
   switchport mode trunk

Verification

Host-1#show port-channel summary 

                 Flags                                                          
------------------------ ---------------------------- ------------------------- 
  a - LACP Active          p - LACP Passive           * - static fallback       
  F - Fallback enabled     f - Fallback configured    ^ - individual fallback   
  U - In Use               D - Down                                             
  + - In-Sync              - - Out-of-Sync            i - incompatible with agg 
  P - bundled in Po        s - suspended              G - Aggregable            
  I - Individual           S - ShortTimeout           w - wait for agg          
  E - Inactive. The number of configured port channels exceeds the config limit

Number of channels in use: 1
Number of aggregators: 1

   Port-Channel       Protocol    Ports               
------------------ -------------- ------------------- 
   Po121(U)           LACP(a)     Et9(PG+) Et10(PG+)

On the Leaf switches we can see the mlag interface status is UP.

Leaf-1#show mlag interfaces members 
Mlag121 is Port-Channel121
  Active Ports: Ethernet9 PeerEthernet10 

Leaf-1#show mlag interfaces 
                                                                   local/remote 
  mlag     desc                      state     local     remote          status 
-------- ------------------- --------------- --------- ----------- ------------ 
   121     MLAG for Host-1     active-full     Po121      Po121           up/up 

Leaf-1#show mlag 
MLAG Configuration:               
domain-id                          :               leafs
local-interface                    :            Vlan4090
peer-address                       :        10.0.199.255
peer-link                          :     Port-Channel999
peer-config                        :          consistent

MLAG Status:                      
state                              :              Active
negotiation status                 :           Connected
peer-link status                   :                  Up
local-int status                   :                  Up
system-id                          :   0e:61:2b:92:79:7c
dual-primary detection             :            Disabled
dual-primary interface errdisabled :               False

MLAG Ports:                       
Disabled                           :                   0
Configured                         :                   0
Inactive                           :                   0
Active-partial                     :                   0
Active-full                        :                   1

The above output shows the MLAG status is Active, peer-link status and local-interface status is UP.

For verification I also did a continuous ping to the gateway IP and shutdown the port on Leaf-1 Eth9 during the ping. This interface is connected to Host-1 on ethernet 9 and this is the results.

1000 packets transmitted, 995 received, 0% packet loss, time 12968ms
rtt min/avg/max/mdev = 5.471/11.717/48.949/6.015 ms, pipe 4, ipg/ewma 12.981/13.516 ms

We see that only 5 packets were lost during this switchover. But to achieve this there is a concept of VARP which is very cool and I will explain in another post.

This concludes this topic.

Unless otherwise stated, the content of this page is licensed under Creative Commons Attribution-ShareAlike 3.0 License